Setting up WordPress to run on Ubuntu/Linux can be a bit tricky with the permissions. If you are trying to install a plugin and get “Unpacking the package… Could not create directory.”, most likely you’re permissions are off on the folder, or apache is likely being run by the wrong user.

Could not create the directory.

You’re plugins directory is located in <WORDPRESS ROOT>/wp-content/plugins. The quick fix you would think would be to chmod 777 wp-content/plugins, HOWEVER you must do the same to wp-content/upgrade as well. This will fix your problem.

chmod 777 wp-content/plugins
chmod 777 wpcontent/upgrade